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What We’ll Talk About

= Goals
= The development environment
= Talking to the RoboRIO

= Making it move

= Resources

= Summary
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Goals

= The goal of this presentation is to help you
understand how to prepare your development
environment for use with C/C++ and Java

= We clearly can’t explain all of the aspects
because we have limited time

» But, you should leave here with a better
understanding of the process

= We will be talking about the set up rather than
the languages themselves

» The WPILIb is equivalent between the
environments
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Why C/C++?

= C/C++Is a standard in embedded systems
programming for over 30 years

» It's still the most predominant language in embedded
L|nu|(>j<, the IoT and the real-time operating system (RTOS)
Wor
 This gives your team valuable real-world experience

" |t's compiled to native machine code

» No virtual machine interpreters
« No pausing due to garbage collection

» It's fast
= |t's the native language of the RoboRIO’s Linux-based
operating system
» The environment is written in C and Assembler
» You get easy, direct access to the underlying O/S
= C++ IS object oriented
» Full support from WPILIb
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Why Not C/C++?

= C/C++ Is compiled
» This adds complexity to the build

= C/C++ Is textual

» There are no cutesy GUIs with lots of obscure
symbols and squiggly lines ©

= There is no VM to catch your mistakes

» The syntax is similar to Java
* Java was derived from C++
* Java VM is written in C/C++

= C/C++ has pointers
» Objects can be referenced in many different ways

» This concept can be troublesome for some
developers
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Why Java?

Java has wide support in the industry

» Object-oriented approach with lots of reference material
Java is the language used on the AP exams

» Used in many computer science classes
Java is a byte-code interpreted language

» The use of the Virtual Machine (VM) allows for many
dynamic language features

The VM will help catch some common memory
mistakes

The version of Java used on the RoboRIO is version 8
from Oracle

WPILIb is actually written in Java and then translated
to C++
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Why Not Java?

= Java Is interpreted
» Performance is lower than C/C++

= Java Is also textual like C++

» But, Java can be written using either imperative or
declarative programming styles

= The version of Java on the RoboRIO Is not
optimized for use Iin control systems

» The version is actually targeted at business
applications

= Garbage collection cycle will cause the robot to
hesitate during the mark-and-sweep cycle

» For the duration of the match, this should not be a
problem
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Top 20 Languages — Nov 2016

= LabVIEW was

Nov 2016 Nov 2015 Change Programming Language Ratings Change
1 1 Java 18.755% 1.65% #34 O N th |S | |St
2 2 c 9.203% 7.94%
3 3 Ct 5.415% 0.78%
4 4 c# 3.659% -0.66%
5 5 Python 3.567% -0.20%
6 8 Visual Basic NET 3.167% +0.94%
7 6 v PHP 3.125% 0.12%
8 7 v JavaScript 2 705% +0.23%
9 11 Assembly language 2.441% +0.56%
10 10 Perl 2.361% +0.33%
11 14 Obijective-C 2 246% +0.82%
12 15 Swift 2.039% +0.80%
13 18 Go 2.001% +1.80%
14 9 ¥ Ruby 1.978% -0.06%
15 16 MATLAB 1.967% +0.78%
16 12 ¥ Delphi/Gbject Pascal 1.950% +0.27%
17 13 ¥ Visual Basic 1.923% +0.24%
18 37 Groovy 1.811% +1.48%
19 19 R 1715% +0.70%
20 18 v PL/SQL 1512% +0.48%
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Getting Your RoboRIO Ready

= Before you can start
development, you'll need
to make sure that your
RoboRIO has the proper
operating system
Image on it
» This is accomplished
using the RoboRIO imaging
tool or it can be done through LabVIEW
= Java developers will need to deploy the Java 8
JDK to the RoboRIO

» We'll address this later...
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Some Useful Info...

" The RoboRIO runs Linux

» SSH server is avallable

« Use Putty on Windows to get
to SSH shell

» File transfers from IDE use
SCP

= Addressing is via mDNS
» roborio-<team #>-FRC.local

EE =<

&~ S,assion Basic options for your PuTTY session
Logging Specify the destination you want to connect to
= Teminal
Host Name (or IP address) Port
- Keyboard
- Bell robaoric-116local 22
- Features Connection type:
- Window ) Raw () Telnet ) Rlogin @ SSH () Serial
ﬁppea@nce Load, save or delete a stored session
- Behaviour
.. Translation Saved Sessions
- Selection roborio-116
- Colours -
Default Settings
[=)- Connection roborio-116 [ﬂ]
- Proxy
- Telnet Delete
- Rlogin
- 55H
- Senal Close window on exit:
® T Mever @ Only on clean exit
[ About l [ Help l ’ Open ] ’ Cancel

= The web server requires Microsoft Silverlight

plug-in
= Do not delete “admin” account
» All program transfers require it
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The Development Environment

* The FIRST-supported development platform for C/C++
and Java is the Eclipse IDE tool

» The beta teams are using the Neon release
» The compiler is the open-source GNU 4.9 compiler
« Supports C++11 extensions
= The C compiler is actually a cross-compiler

» We are building on an x86 for an ARM-based system

« Again, this is a standard approach for commercial, embedded
development

= There Is also a way to install the Java bytecode
compiler for Eclipse after you install the FRC plugins

» RoboRIO runs Java bytecode in the Oracle JVM

» Compiler on development platform produces the
bytecode
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Development Environment #2

= During the beta, FIRST Is only supporting
Windows

» However, libraries and compilers are available for
OS/X and Linux

"= The beta supports Windows 10

» You can still run it in a virtual machine
 For all you Mac OS/X and Linux fans

" 64-bit Windows Is supported

= The Java 8 JDK needs to be installed on your
platform regardless of whether you use Java or
C/C++

» Make sure you install the JDK and not just the JRE
» http://java.com
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The Eclipse Neon IDE

= To get started, first install
Oracle Java 8 JDK on the
Windows host

» Either 32- or 64-bit
depending on your host

= Next, go to Eclipse.org and
download the Eclipse IDE for C/C++ developers
» 32- or 64-bit version to match your Java install
» Works for both C/C++ and Java development
= Once installed, you'll connect to FIRST to
download the plug-ins for development
» This may change for kick-off
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Installed Eclipse

S C/C++ - Eclipse =N E=H(E>=)
File Edit Source Refactor Mavigate Search Project WPILIb Run  Window Help
Ta CACINEAE T IE S GO R @S 5 B
Quick Access %\| Hej C/C++ a’Ja\ra
L5 Project Explorer &3 = 0O = d =03 ! = 8
= % = =

An outline is not available,

El Console &3
Mo consoles to display at this time.
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Install FRC 2017 Update Suite

= First, make sure you remove any old
LabVIEW or driver station code
= Run the update suite installer

» This will install the RoboRIO imaging tool and the
latest firmware release

» Installs the latest driver station and
smartDashboard

= The 2017 Driver Station doesn’t look that
different from the 2016 version

» So far...
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2017 Driver Station

22| FRC PC Dashboard

No Camera Selection

No Camera Selection A 4

TeleOperated
Autonomous
Practice

Test
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320x240 15fps 30%

0:00.0

Elapsed Time

-4 PCBattery
PCCPU% m

Window

Team Station Red1

Drive  Camera Basic Custom

Joysticks

Drive Motors

Front

Back

® NT Connection

No Camera Selection A 4

0 fps

Team # 116

1235V

Communications
Robot Code mm
Joysticks

Teleoperated
Disabled

Test Commands Checklist Variables

Gyro 0

I
360

Select Autonomous ... L |

3200240 15fps 30%
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Checking for Java

= |f you're working with
: T ——— =T X
Java, you'll need to — R

= > (General
ve I’Ify th at th e J ava - Ant If Java is missing, then do  |° =
. : E-;;C“ L the next step, otherwise  Jge Explorer
tools are installed et
> Mylyn (71 Open a new Type Hierarchy Perspective

= Normally, you won't
have to go beyond oS

+ Specfile Editor
. Team Refactoring Java code

this step if you o Pl et s sy o i
Installed the Oracle ® ] o

Java on your |
development station

correctly

When opening a Type Hierarchy

@ Show the Type Hierarchy View in the current perspective
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Find the Java Development Tools

= |f for some reason, Java o

, ] Work with:  Luna - http//download.eclpse.org/releases/luna
d OeS I I t S I I OW u p I I I tI l e Find more software by working with the “Available Software Saes” pref
Version 2
. J
rev I O l l S ta O l l n e e to Paralled ) Toolchain Support 84.0.20140611175
, \° gr T/Ce s Call Graph Visualization 3.0.0.20140610040
N 711§ C/C~+ Development Took SDK £4.0.20140611175,
- g4 C/Ce» IBM XLC Compiler Support £4.0.20140611175
g4 C/Ces LLVM-Family Compiler Build Support 1.0.0.20140611175
§h C/Cs+ Multicore Visuaizer 54.0.20140611175
b C/Ce+ Qt Support 1.1.0.20140611175 =
g+ C/C++ Remote (over TCF/TE) Run/Debug Launcher 1.20.201405271122
s C/C++ Unit Testing Support £4.0.20140611175,
s C/Ces UPC (Unified Parallel C) Support 840.20140611175
, g+ Code Recommenders for Java Developers 210.,v201405610-1:
. ig4 Code Rec ders Mylyn Integrati 2.1.0.,20140508-1
J» Code Recommenders Snipmatch 210.v20140606-1;
, igh Dynamic Languages Toolkit - iTel Develop Tools 5.0.0.20130606070
ig4 Dynamic Languages Toolkit - Ruby Development Tools 5.00.20130506070
- \ | 'g+ Dynamic Languages Toolkit - TCL Development Tools 50.0.20130806070
lopment Tools 5.0.0.20130506070
3.100.v20140606-
360.v2014050621
« mn L
— — | All Deselect All | 1 item selected
type filter text Installed JREs PYTOTe o
ails
;7:::;‘“ T Add, remove or edit JRE definitions. By default, the checked JRE iz added to the build path of newly created Java -
I
projects,
Code Style e
Compiler Installed JRE: *
Debug Add l =
a ]ntalle‘d JREs 3 1 Edit... | Show only the latest versions of available software v Hide items that are already installed
TRy o u— | 71 Group items by category What is alrasthy installed?
Mnit (uPuplicate. ) ‘( Show only software applicable to target environment
P ies Fil
sopesties Files Editor | Remove [ Il ViContact all update sites during install to find required software
Library Hover —
Mytyn Search.. |
Remate Systeme ' i ‘
< = 1
& OK [ Cancel | l @ 2 ‘ Cancel
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Install the Third-Party Libraries

" FIRST has unbundled the libraries for motor
controllers like the CTRE Talon SRX

» This will likely include anything that has any special
capabilities like the Rev Robotics SPARK as well
" You'll need to contact the manufacturer to get the
Instructions for integrating their product into the
Eclipse environment

» Typically an installer for Windows
« OS/X and Linux will have to piece it together

= You'll need to add the libraries and header files to
the search path of your project
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Now, Java Should Work (on the Host)

= Once you've verified that the Java tools and
JDK are visible to Eclipse you should be able
to use the File->New->Project option to select
and create a new Java-based robot project

= This process looks almost identical to the
steps for C/C++

» For the sake of time we’ll show the C++ steps,
but the Java steps are similar
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Java on the RoboRIO

= Java does not come installed on the RoboRIO
» Issues with the license from Oracle

" You need to have your host connected to both
the RoboRIO and the Internet

= cd to C:\Users\<username>\wpilib\tools and
run java-installer.jar

= Follow the prompts, accept the license and let
the system install Java to the RoboRIO

» Repeat for each RoboRIO
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Creating A Project

= Eclipse collects all of the files related to
building a piece of code into a subdirectory
called a project folder

» It's normally stored in your C:\users account

* You can put the project elsewhere when you open
Eclipse

" You can also import and export projects

» This allows you to create a .zip of the project for
archival purposes

= To create a new project use:
» File->New->Project and select WPILIb Project
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New

Project -

Simple Robot

o Mew Project

Select a wizard

Wizards:

=[O =]

.

»

»

= General

= CfC++

= Createrepo

= CV5

= lava

= RPM

= Tracing

= WPILib Rebot C++ Development
Examnple Robot C++ Project
Robot C++ Project

= WPILib Rebot Java Development
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Finish

= = [[2-=s]
Create New Robot C++ Project

€3 Project name must be specified

Project Mame:

Project Type

Command-Based Robot: A robot project that allows robots to be implemented using
@ the command based model to allow complex functionality to be developed from
simpler functionality.

- Iterative Robot: A robot project that allows robots to be implemented in an iterative
~ manner,

-~ sample Robot: A robot project used for small sample programs or for highly
~ advanced programs with more complete control over program flow

Simulation World:  fusr/share/fresim/worlds/GearsBotDermao.world Browse
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ew Project Result

I Project Explorer 23 = B8 [€] Robot.cpp 2 = 08 |50 » =8
=i =S - : #include "WPILib.h" » PO R e %
i . <
< & In:eraltwel 3= class Robot: public IterativeRobot =
$ IB'”l"":S 4 5 WPLibh
» [npt) Includes 5 private: Robat
» (= Debug 6 LiveWindow *1w; + © Robo -
- o lw: LiveWindow®
4 src ’ . .
& [3 Robot a g void RobotInit() @ RobotInit() : void
* L] hobat.cpp 9 { B AutonomousInit()
bU!"j-P"UF]E"t'EE _3 Iw = LiveWindow::GetInstance(); m AutonomousPeriod
-;g_é]bulld.xml 1 ¥ m  Teleoplnit( : void
L - -
all woid AutonomousInit() | @ TeleopPeriodic() : v
14 { T m  TestPeriodic(): void
15 @ main():int
5 )
ald void AutonomousPeriodic()
19 {
21 }
22
a3 void TeleopInit()
24 {
25
26 }
Pt void TeleopPeriodic()
29 i
38
31 }
32 i N a
. b ] T +
& Console &1 @ﬁ}| @l @H :Ea|="E'i=J'='EI
CDT Build Console [Interative]
arm-frc-linux-gnueabi-g++ -std=c++ly "-IC:\\Users\\mike/wpilib/cpp/current/include” “-IC:\\Wsers\\mike\\wo *
arm-frc-linux-gnueabi-g++ "-LC:\\Usersh\\mike/wpilib/cpp/current/1ib" -Wl,-rpath,/opt/GenICam v2_3/bin/Linu
c:/frc/bin/../lib/gcc/arm-fre-1inux-gnueabi/4.9.1/../.. /.. /.. farm-frc-linux-gnueabi/bin/ld.exe: warning: 1
23:48:43 Build Finished (toock 65.427ms) 1
F] 1 o b
Writable Smart Insert 1:1
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Build the Project

L’y Project Explorer 52 = 0

= Eclipse will default to building ... =

= i .
Open in Mew Window

the project automatically

X Paste
3 Delete

= However, you can clean and = oo
build the project manually

= Use the Project menu to e
configure the auto-build o

Build Cenfigurations

feature

Index

L
)

Profiling Tools
Profile As
Debug As

Run As
Compare With

[] Robot.cpp 52

Ctrl+C
Ctrl+V
Delete
Ctrl+Alt+Shift+Down

F2

F3

Show in Remote Systems view

Restore from Local History..,

%"‘ Run C/C++ Code Analysis

Team

5 Interativ .
Properties
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Set Team # In Preferences

= Preferences

type filter text

>

>

>
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General

Ant

CiC++
Changelog
Createrepo

Help
Install/Update
lava

Library Hower
Mylyn

Remote Systems
Run/Debug
Specfile Editor
Team

Terminal
Tracing

WPILib Preferences

WPILib Preferences

A preference page for changing all workspace level settings.

Tearmn Mumber: 114

Tools Version:

"] Auto Update Tools Version

EA- FRC Team #116



Deploying to the Target

= When the code is built, you
can select Run As->WPILib C++ Deploy

Debug As b |-|-+ -std=c++1ly "-IC:%\\Usersi\mike/w)
Run As b | [£] 1Local C/C++ Application 3
Compare With b 2 WPILib C++ Deploy
Restore from Local History... 2 3 WPILib C++ Simulation

%& LT B B S ST Run Cenfigurations...

= This will open an SCP connection to the
RoboRIO (as "admin™) and copy the application to
the file system

= The application will then start running
» Waiting for the driver station
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Debugging Code

" The project is usually automatically created
with debugging enabled

= Select Debug As->WPILib C++ Deploy

" The Eclipse will automatically switch to the
Debug perspective

" You can then set breakpoints

= Once the driver station enables the
application, your debug session will begin
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The Eclipse Debug Perspective

2 Debug - Getting Started/src/Robot.cpp - Eclipse
Refactor Mavigate Search  Project WPILIb  Run  Window Help
: EARTIB 0 m®E 5

Quick Access

File Edit Source
Tw BT &5 P
35 Debug i1

[£] Robot.cpp 2

#include "WPILib.h™

Mo consoles to display at this time.

FRC C++-Introduction-29

iz == O

(x)= Variables 3

2

3= class Robot: public IterativeRobot

41

>

6 RobotDrive myRobot; // robot drive system

7 Joystick stick; // only joystick

8 LivelWindow *1lw;

9 int autolLoocpCounter;

16

11 public:

12 Robot() :

13 myRobot (@, 1), ' these must be initialized in the same order
14 stick(a), '/ as they are declared above.
15 Iw{NULL),

16 autolooplounter(@)

4

&l Console &2

=

8

-

m

oo =]

- - - -
ﬁ” MR C/C++ & Java
5 B & ciet == 8
2
0= Outline &3 = 8
SHERISEEEE
= WPILib.h -
4 (3 Robot
o myRobot: RobotDrive
o stick: Joystick
o lw: LiveWindow®
o autocloopCounter: int =
@ Robot()
m  RobotInit() : void
®m  Autonomousnit() : void
B AutonomousPeriodic() : voidl
@ Teleoplnit() : void
B TeleopPeriodic() : void -
4| mn 3

mv=18
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Resources

= Chief Delphi
» http://www.chiefdelphi.com
= FIRST forums
» http://forums.usfirst.org
= NI Community Forums
» http://ni.com/FIRST
= WPI / FIRST NSF Community site (ThinkTank)

= These sites are monitored members of:

» WPI
» NI
» FIRST

= All source code available for team<->team
assistance

"= Phone support through NI
» 866-511-6285 (1PM-7PM CST, M-F) ?
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Summary

= C/C++ can be very challenging to new developers

» C/C++ Is similar enough to Java that Java developers can
adapt to it quickly
« However, pointers will require some explaining

» Performance and fine-grain control are the biggest advantages
to using C/C++

= Java has a lot of support within the FIRST community and
many school systems
= Being on the AP CS exam encourages schools to teach it

= Java s also used in the new FTC development environment
= Although the Java VM is slightly different for Android

= WPILIib class libraries have equivalent capability between
C++ and Java versions

= Java and C++ are syntactically very similar

= You could start with one and then switch without too much
trouble
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